google play 11.0.4 with pushwoosh crash issue

Comments

1 comment

  • Avatar
    Ivan Skoritzky

    Matt,

    As far as I can see, my colleague Vitaly have already answered your question in the support ticket.

    Just in case, I will copy his answer in order for other visitors to see it:

    Pushwoosh Android SDK and Pushwoosh Unity plugin, in particular, do support Play Services v11. I have checked the plugin you reference and it seems that it does not support GCM at all. The plugin does not contain com.google.android.gms.gcm package and it should be manually added. Please refer to the following issue in this plugin's repo:

    https://github.com/playgameservices/play-games-plugin-for-unity/issues/883

    You can always find .aar of Play Services packages in the following directory:

    $ANDROID_HOME/extras/google/m2repository/com/google/android/gms/play-services-gcm/11.0.4/play-services-gcm-11.0.4.aar

    For example, on my Mac it is located in /Users/pushwoosh/Library/Android/sdk/extras/google/android/gms/play-services-gcm/11.0.4/play-services-gcm-11.0.4.aar

    Please make sure that you have a required version of the lib installed via Android SDK Manager.

    You will also have to include some other Google Play Services packages. You can find it listed here:

    https://github.com/Pushwoosh/pushwoosh-unity/tree/master/PushwooshUnitySample/Assets/Plugins/Android

    Just replace 9.6.1 versions with 11.0.4. Also, the plugin you currently use might have some of these packages included. In this case, you will catch a dexer exception (already added). Then remove one of the instances and you should be fine.

    Regards, Ivan

Please sign in to leave a comment.