Notifications send with 2 hour delay (same as timezone difference)

Comments

10 comments

  • Avatar
    Yoav

    i have the same problem, just different delay.

  • Avatar
    Andro Delrue

    Is your delay the same as your timezone difference?

  • Avatar
    Yoav

    yes, 3 hours (2 hours + 1 hour daylight delay).

    I tried to use: ignore_user_timezone : false

    Now it's bit better (less delay) but still not working properly. It seems that there is problem with DST (Daylight Saving Time) among part of devices when using "ignore_user_timezone" parameter.

  • Avatar
    Andro Delrue

    Did this problem occur in August for you as well?

  • Avatar
    Yoav

    yes, since 03/08

  • Avatar
    Alexander Belyaev

    Hi there!

    Thank you for pointing this out.

    Yes, you are correct. It seems that there is an incorrect behaviour of "ignore_user_timezone" parameter.

    Please note that our developers are already looking for the root cause of the issue.

    Kind regards, Alex

  • Avatar
    Andro Delrue

    Can you let us know when this is fixed and what the problem was exactly? I will have to report back to my superiors. Thanks in advance

  • Avatar
    Alexander Belyaev

    Hi, yoav!

    The developers have informed me that this issue has been fixed. Could you check it, please?

    Kind regards, Alex

  • Avatar
    Yoav

    Hi Alex,

    I still have problem with notifications. Now i have "delay" of "-3" hours instead of "+3".

    Maybe the reason for that can be my parameters usage?

    My usage (example):

    send_date = 09:29 ignore_user_timezone = false timezone = "Asia/Jerusalem"

    Results (from today 10.08):

    send_date = 06:29

    Should i remove "timezone" parameter? What happens when using both parameters "ignore_user_timezone" and "timezone"?

    Thank you for your update.

    Best Regards, Yoav

  • Avatar
    Alexander Belyaev

    Hello Yoav,

    Thank you for the information provided.

    Actually, it is quite strange since the user roularta has informed me in a support ticket that its pushes are working correctly after the fix.

    In order to investigate this case in more details, could you please contact us using the form below or directly from your Control Panel?

    Looking forward to your email!

    https://www.pushwoosh.com/contact-us/

    Kind regards, Alex

Please sign in to leave a comment.