Unable to unregister device

Answered

Comments

3 comments

  • Avatar
    Gayview Mahat

    Hello! Can you confirm that you have done the following?

    1. Whitelisted *.pushwoosh.com domain in the config.xml file:

      <access origin="*.pushwoosh.com"/>

    2. Added cordova plugin add cordova-plugin-whitelist

  • Avatar
    Djulbic

    Hi! Thx for fast answer.

    I have, in config.xml:

    <access origin="*"/>

    and i have added cordova plugin add cordova-plugin-whitelist, but same error remains.

    Also i have noticed this message in console

    No Content-Security-Policy meta tag found. Please add one when using the cordova-plugin-whitelist plugin.

    Could it be related ?

  • Avatar
    Rainer Oechsle

    Hi everyone,

    is there a solution for this problem?

    I got the same error registering a device using the Ionic/Cordova Plugin and I ran it on a real Android device:

    Log level: NOISE [PushManager] This is android device [RequestManager] Try To send: registerUser [PushRegistrarGCM] number of receivers for io.ionic.starter: 4 [PushRegistrarGCM] Found 1 receivers for action com.google.android.c2dm.intent.RECEIVE [DeviceRegistrar] Registering for pushes [PushEventsTransmitter] No android.permission.BROADCAST_STICKY. Reverting to simple broadcast [RequestManager] Try To send: applicationOpen [RequestManager] ERROR: failed to connect to cp.pushwoosh.com/127.0.0.1 (port 443): connect failed: ECONNREFUSED (Connection refused). Response = null 04-11 16:58:19.923: E/Pushwoosh(10037): java.net.ConnectException: failed to connect to cp.pushwoosh.com/127.0.0.1 (port 443): connect failed: ECONNREFUSED (Connection refused) 04-11 16:58:19.923: E/Pushwoosh(10037): at libcore.io.IoBridge.connect(IoBridge.java:114) 04-11 16:58:19.923: E/Pushwoosh(10037): at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:192) 04-11 16:58:19.923: E/Pushwoosh(10037): at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:460) and so on ...

    EDIT: I found the problem. I have "AdFree-App" installed which uses localhost to block ads. When I turned of this App, it worked. When the App was turned on, I could not load the site https://cp.pushwoosh.com/ in any android browser ...

Please sign in to leave a comment.