PhoneGap Build... plugin from cordova or pgb repository?

Answered

Comments

5 comments

  • Avatar
    Max Konev

    Wow. That's a big change! The best plugin and the freshiest plugin is always this one:
    https://github.com/Pushwoosh/pushwoosh-phonegap-3.0-plugin

    Due to a numerous restrictions of PGB built-in plugins Pushwoosh PGB plugin misses some features (for example Windows Phone 8 support).

    The interface for both (PGB and CLI) plugins are the same so you shouldn't notice the difference!

  • Avatar
    izbuh

    Ok, but which is the url to set in the config.xml?

    If I use: <gap:plugin name="https://github.com/Pushwoosh/pushwoosh-phonegap-3.0-plugin.git" source="plugins.cordova.io"/>

    PGB reply me "plugin unsupported" and block the app build process.

  • Avatar
    izbuh

    Ok, found the solution: <gap:plugin name="com.pushwoosh.plugins.pushwoosh" source="plugins.cordova.io"/>

  • Avatar
    izbuh

    ... is necessary/suggest to indicate the version for cordova's plugin version?

    example: <gap:plugin name="com.pushwoosh.plugins.pushwoosh" version="3.4.5" source="plugins.cordova.io"/>

  • Avatar
    Max Konev

    It wouldn't make any harm to indicate the version. But it could be omitted.

Please sign in to leave a comment.