Unkown Device when send push to one device token

Comments

5 comments

  • Avatar
    Max Konev

    Do you have this device registered in the system? Test device bypass this check.

  • Avatar
    kholoud

    Yes, the device was registered.

    I knew the problem caused as "devices" parameter contained less than 10 devices

    from Remote API Guide: If the Debug Mode is turned OFF, and you send the /createMessage request that contains less than 10 device tokens to Pushwoosh API, the server returns the “CODE_NOT_AVAILABLE” value for “Messages”, and an empty key for Unknown Devices instead of the Message Code. https://www.pushwoosh.com/programming-push-notification/pushwoosh-push-notification-remote-api/#PushserviceAPI-Method-messages-create

    when I turn on Debug mode the response changed but debug mode turn off automatically after 1 hour. I want to ask if there is a way to send notification for devices less than 10 without turn on debug mode.

    Thanks for your help.

  • Avatar
    Max Konev

    Does it work fine with DEBUG mode? Could you send your token and createMessage request?

  • Avatar
    Vibrantappz

    Getting same response":{"Messages":["CODE_NOT_AVAILABLE"].... When I used same token in test devices and notification not delivered.

    Invalid token: 1 Total: 1

  • Avatar
    Max Konev

    This is CORRECT response! First thing you should check is that Gateway in the app configuration matches the provisioning profile.

Please sign in to leave a comment.