Cordova CLI 4.0.0 Pushwoosh Plugin Build Errors

Comments

6 comments

  • Avatar
    Max Konev

    Do you use 3.4.0 version of the Pushwoosh plugin?

  • Avatar
    oliverdalton

    Hi shader,

    Thanks for the reply - yes I an using 3.4.0 I just checked that by cat'ing the plugin.xml file this is the header. <?xml version="1.0" encoding="UTF-8"?> <plugin xmlns="http://apache.org/cordova/ns/plugins/1.0" xmlns:android="http://schemas.android.com/apk/res/android" id="com.pushwoosh.plugins.pushwoosh" version="3.4.0">

    <name>Pushwoosh</name>
    
    <description>
    This plugin allows you to send and receive push notifications. Powered by Pushwoosh (www.pushwoosh.com).
    </description>
    

    Is this the correct version to be using? Do I need to downgrade the version of the plugin?

    Kind Regards

  • Avatar
    Max Konev

    try the following commands:
    cordova plugins list

    It should say the correct version of Pushwoosh plugin.

    Sometimes Cordova build system get mixed up and the only way to solve this is to remove plugin completely and add it back.

  • Avatar
    oliverdalton

    Hi shader,

    Below is the output from the cli you suggested.

    cordova plugins list

    com.pushwoosh.plugins.pushwoosh 3.4.0 "Pushwoosh"

  • Avatar
    Max Konev

    What will happen if you remove the plugin completely and re-add it? Also do you build it from Console or Eclipse?

  • Avatar
    Jianbo Cui

    Im having the same problem

    Fetching plugin "https://github.com/Pushwoosh/pushwoosh-phonegap-3.0-plugin.git" via git clone Installing "com.pushwoosh.plugins.pushwoosh" for android

    List: com.pushwoosh.plugins.pushwoosh 3.4.11 "Pushwoosh"

Please sign in to leave a comment.