android integration problem

Answered

Comments

4 comments

  • Avatar
    Dmitry Dyudeev

    Hello,

    Please double check your AndroidManifest file. Most probably, you have forgotten to put your AppCode and/or Google Project number.

    <meta-data android:name="PW_APPID" android:value="your_app_ID" />
    <meta-data android:name="PW_PROJECT_ID" android:value="your_Google_project_number" />
    
  • Avatar
    Herencia Del Beagle

    Hello again.

    That parameters were introduced but in a wrong way.

    Due to poor understanding of the documentation (my English is... sad), I had put the data in a wrong place.

    Thanks for help.

  • Avatar
    Andreas Lundgren

    Could you please specify what you mean by "the data in a wrong place" and how did you change the data to make it work for you?

    I have the same problem as you and I believe I have inserted the parameters into my AndroidManifest.xml as required in the tutorial here: http://docs.pushwoosh.com/docs/native-android-sdk

    Here is how mine looks:

    <meta-data android:name="PW_APPID" android:value="CE926-E152D" />
    <meta-data android:name="PW_PROJECT_ID" android:value="A794336915285" />
    
  • Avatar
    Andreas Lundgren

    Okay, I solved it now. Here is how:

    I accidentally placed the meta-data tags outside the application tag. They should go inside the application tag in AndroidManifest.xml, at the very top, like so:

    <application
        android:allowBackup="true"
        android:icon="@mipmap/ic_launcher"
        android:label="@string/app_name"
        android:supportsRtl="true"
        android:theme="@style/AppTheme" >
        <meta-data android:name="PW_APPID" android:value="CE926-E152D" />
        <meta-data android:name="PW_PROJECT_ID" android:value="A794336915285" />
    

    Hope this helps someone!

Please sign in to leave a comment.