"Your provisioning profile does not have APS entry" error

Answered

Comments

16 comments

  • Avatar
    Alexander Spotar

    You should check your mobile provisioning profile and make sure it contains the “aps-environment” string. If it is not there, you should recreate the mobile provisioning profile in the Apple Development Portal. However, as you are using Auto Configuration for iOS, you can select the "Make my profile compatible" option in the last step of our wizard. Make sure the “aps-environment” value matches the gateway you are using: Sandbox for “development” and Production for “production” values.

  • Avatar
    Dans

    I followed your instructions but still received the same error message.

  • Avatar
    brownbw

    I am also getting this same error. I've tried every way possible. Provisioning file does contain the ape-environment string... I am not using the auto config.

  • Avatar
    Leoabacade

    does someone solve this issue?

  • Avatar
    masakre

    i've suffered this issue and i was able to fix it by editing the provision profile (make sure that all devices are checked in apple developer portal), after enable all devices, go to pushwoosh app config page and make that provision profile pushwoosh compatible (using pushwoosh assistant) after that download & install the provision profile from apple developer portal.

  • Avatar
    Greg_Nth

    1.3k views and there is still no answer to this problem. Can someone from Pushwoosh please directly address and solve this issue, in this thread?

  • Avatar
    sebe

    Gaaah!! Been sitting with this issue for to long now... Same issue as mentioned above... anyone of you got a solution yet?

  • Avatar
    client62345

    yes, my solution was to install an ad hoc provision profile on the device, so create an ad hoc provision file in the apple dev center, download it and open it on your test device (via email for example). After installing the provision profile the error massage no longer appeared and push worked directly.

    cheers!

  • Avatar
    Bdupuis

    Evaluating the service and I have this error as well. My Provisioning Profile does contain the aps-environment entry and my app is properly configured by following the instructions.

    Is that a PushWoosh issue or am I missing something?

    Thank you

  • Avatar
    Max Konev

    Make sure your provisioning profile is push compatible and has "aps-environment" string in it.
    Make sure you sign with the correct provisioning profile. Sometimes if you have two profiles for the same App ID XCode can mess up and sign with the old one.

    The recommended steps are:
    1. Remove all XCode profiles (http://stackoverflow.com/questions/18923095/delete-provisioning-profile-from-xcode-5)
    2. Add the one and only new profile.
    3. Rebuild the app.

  • Avatar
    mvandillen

    I had the same problem after following all steps. The solution that worked for me was to go to XCode Preferences, tab Accounts, select the correct Apple ID, click View Details... and click the refresh button with the arrow on it on the left bottom corner. This refreshed all Provisioning Profiles registered at Apple. After a clean build of the project the error went away.

  • Avatar
    leocardz

    You have to create an Provisioning File on Apple Developer Center that match your Bundle Id. After that, download *.mobileprovision and add it on Xcode by double-clicking it. Then in Target > Build Settings > Code Signing > Code Signing Identity, set choose your Provisioning File related to your app.

  • Avatar
    Sitaram Sanaka

    i fallowed same steps from link "https://www.pushwoosh.com/programming-push-notification/ios/ios-configuration-guide/" and i have "aps-environmen" in provisining profile and when i am running in device from xcode its working fine but when i create build and install in device i am getting error "Your provisioning profile does not have any APS entry. Please make your profile push compatible" i have live project but pushwoosh not working i need to update next version its heigh pririty any one can help?

  • Avatar
    Sitaram Sanaka

    i had same problem not resolved still i fallowed same steps from link "https://www.pushwoosh.com/programming-push-notification/ios/ios-configuration-guide/" and i have "aps-environmen" in provisining profile and when i am running in device from xcode its working fine but when i create build and install in device i am getting error "Your provisioning profile does not have any APS entry. Please make your profile push compatible" i have live project but pushwoosh not working i need to update next version its heigh pririty any one can help?

  • Avatar
    Michael

    I'm having similar problems. I can push an app to my device using Xcode. Notifications work. When I archive and send to Test Flight using distribution profile, no notifications. I can see aps-environment is included. I re-done my provisioning profiles and certificates 3 times now. I've been back and forth with Pushwoosh tech support for a month and I'm a paying customer. They have looked at all my code, certs, profiles, etc. and can't find any problems. Nothing seems to be solving the problem.

  • Avatar
    David Payette

    OK, my problem was that the name of my app in Xcode wasn't the same as the provisioning profile / whatever that I created on Apple Developer Portal. I had automatically manage signing turned on, so Xcode created an App ID automatically in the portal called XC com paye... whatever — so I added the push notifications certificates and stuff to the app that Xcode created up there in the development section and it worked.

    This problem was a PIMA! It's such a simple fix — I really hope this helps!

    David

Please sign in to leave a comment.